Some users experiencing login issues

Incident Report for Ninety

Resolved

This incident has been resolved.
Posted May 21, 2025 - 17:38 UTC

Identified

We have identified this issue and preparing a fix. If you are experiencing login issues on one of our partner domains please try to login using app.ninety.io before contacting our client support.
Posted May 21, 2025 - 17:14 UTC

Investigating

We are investigating an issue with login functionality
Posted May 21, 2025 - 16:46 UTC
This incident affected: app.ninety.io.