Degraded Performance for Companies with a large amount of Users

Incident Report for Ninety

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 17:45 UTC

Monitoring

We have pushed a fix which has improved performance, we are monitoring for measured improvements.
Posted Feb 04, 2025 - 22:27 UTC

Update

We have pushed a fix which has improved performance, we are monitoring for measured improvements.
Posted Feb 04, 2025 - 22:25 UTC

Identified

We’ve identified inefficiencies in the users select caused by previous changes. Fix to be deployed shortly.
Posted Feb 04, 2025 - 21:40 UTC

Investigating

We are currently investigating this issue.
Posted Feb 04, 2025 - 20:59 UTC
This incident affected: app.ninety.io.