Reports of Performance Issues Following Scheduled Maintenance

Incident Report for Ninety

Resolved

This incident has been resolved.
Posted May 14, 2025 - 18:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 17:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2025 - 16:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2025 - 15:52 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2025 - 15:09 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2025 - 14:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 13:48 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 12:37 UTC

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 12:01 UTC

Investigating

We're currently investigating reports of loading slowness, spinning loaders, or pages not displaying properly following our recent maintenance. Our team is actively working to identify the root cause and restore full performance as quickly as possible.
Posted May 14, 2025 - 11:57 UTC
This incident affected: www.ninety.io and app.ninety.io.