Quarterly and Annual 1:1s unable to load

Incident Report for Ninety

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 16:03 UTC

Monitoring

A fix has been implemented we are monitoring the results.
Posted Aug 27, 2026 - 16:01 UTC

Identified

We have identified the issue and are working towards a fix.
Posted Aug 27, 2026 - 15:40 UTC
This incident affected: app.ninety.io.