Some clients are experiencing latency or message failure issues with Maz

Incident Report for Ninety

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 13:01 UTC

Investigating

We are currently investigating the issue and thank you for your patience.
Posted Oct 20, 2025 - 16:35 UTC
This incident affected: app.ninety.io.