Microsoft Single Sign-On Errors

Incident Report for Ninety

Resolved

This incident has been resolved, Microsoft Single Sign-On is now functioning as expected.
Posted Aug 18, 2025 - 15:13 UTC

Investigating

We are currently investigating reports of Microsoft Single Sign-On errors not allowing users to login. If you have an email and password with Ninety.io you can continue to use that method of login while we remedy our Microsoft option.
Posted Aug 18, 2025 - 14:22 UTC
This incident affected: app.ninety.io.