Signing up and inviting new customers failing

Incident Report for Ninety

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 02:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 02, 2025 - 22:53 UTC

Investigating

Emails are currently not being sent for new sign ups, invitations, or password resets we are actively investigating this issue and appreciate your patience.
Posted Dec 02, 2025 - 20:19 UTC
This incident affected: app.ninety.io.