Zapier Integration - Some users experiencing rate limiting

Incident Report for Ninety

Resolved

We have resolved the issue with Zapier, if you have errored runs in your Zap history attempt to replay those Zaps.
Posted May 11, 2026 - 19:24 UTC

Identified

We have identified the issue with Zapier and are working on a fix.
Posted May 11, 2026 - 18:07 UTC
This incident affected: app.ninety.io.