Billing Outage

Incident Report for Ninety

Resolved

This outage has been resolved. Customers can now create companies and interact with billing features as usual.
Posted Oct 10, 2024 - 20:04 UTC

Identified

We are aware of an issue where customers cannot create companies or interact with their billing features. We have identified the problem and will publish updates once this outage has been resolved.
Posted Oct 10, 2024 - 19:53 UTC
This incident affected: app.ninety.io.