Live Chat Support Latency

Incident Report for Ninety

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:29 UTC

Investigating

Live Chat & Messenger Impacted:

We are continuing to experience degradation from the continued major outage affecting Amazon Web Services (AWS) in the US-East-1 region.

Our teams are working closely with AWS and continuing efforts to stabilize the platform and reduce latency, but we expect customers to continue to see periods of elevated latency and increased error rates until services are fully restored.
Posted Oct 20, 2025 - 17:25 UTC
This incident affected: www.ninety.io.