Ninety Billing Update

Incident Report for Ninety

Resolved

This incident has been resolved.
Posted May 24, 2024 - 14:40 UTC

Monitoring

Ninety recently transitioned some subscriptions to a new billing provider to enhance the billing experience. It has come to our attention that during this transition these companies may have received a notification that their Ninety subscription was cancelled. We apologize for this incorrect notification - Please rest assured these Ninety accounts remain active and no actions need to be taken as a result of this change.
If you have any questions or concerns regarding this change, please feel free to reach out to us directly.
Posted May 24, 2024 - 01:48 UTC
This incident affected: app.ninety.io.