Accountability Chart - Some companies experiencing errors

Incident Report for Ninety

Resolved

The issue with service is now fully functional. Thank you for your patience.
Posted May 21, 2026 - 19:56 UTC

Investigating

The service is not functioning as expected, we have begun our investigation into the issue.
Posted May 21, 2026 - 17:01 UTC